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Abstract: Relying on previous publications and tools (Bob, 2010; Costes et al., 2004; Dunn et al., 

2011; Fiji/ImageJ program web site, 2020; Herbert, undated; Fiji/ImageJ program documentation, 

2020; Online Manual for the WCIF-ImageJ collection, undated; Stauffer et al. 2018), this current 

document describes a method developed by Lauri Lahti and how he used this method to perform the 

co-localization analysis and create the results that are reported in the research article Abouelezz, 

Stefen, Segerstråle, Micinski, Minkeviciene, Lahti, Hardeman, Gunning, Hoogenraad, Taira, Fath, 

& Hotulainen (2020), "Tropomyosin Tpm3.1 Is Required to Maintain the Structure and Function of 

the Axon Initial Segment". 

 

 

Introduction 

 

Relying on previous publications and tools (Bob, 2010; Costes et al., 2004; Dunn et al., 2011; 

Fiji/ImageJ program web site, 2020; Herbert, undated; Fiji/ImageJ program documentation, 2020; 

Online Manual for the WCIF-ImageJ collection, undated; Stauffer et al. 2018), this current 

document describes a method developed by Lauri Lahti and how he used this method to perform the 

co-localization analysis and create the results that are reported in the following peer-reviewed 

scientific journal article: 

Abouelezz, Amr; Stefen, Holly; Segerstråle, Mikael; Micinski, David; Minkeviciene, Rimante; Lahti, 

Lauri; Hardeman, Edna C.; Gunning, Peter W.; Hoogenraad, Casper C.; Taira, Tomi; Fath, 

Thomas; & Hotulainen, Pirta (2020). Tropomyosin Tpm3.1 is required to maintain the structure 

and function of the axon initial segment. iScience. 2020 Apr 12;23(5):101053. DOI: 

10.1016/j.isci.2020.101053. https://www.sciencedirect.com/science/article/pii/S2589004220302388 

and https://doi.org/10.1016/j.isci.2020.101053 

 

Lauri Lahti's author contributions for the above-mentioned journal article (Abouelezz et al., 2020) 

include that he performed the co-localization analysis and also participated in writing, reviewing, 

commenting and editing the manuscript. Among other things, the methods and results of the journal 

article (Abouelezz et al., 2020) rely on measuring properties of the membrane periodic skeleton of 

the axon initial segment using cultured rat hippocampal neurons and 3D-structured illumination 

microscopy (3D-SIM). 
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Method for performing the co-localization analysis concerning 

properties of the membrane periodic skeleton of the axon initial 

segment using cultured rat hippocampal neurons and 3D-structured 

illumination microscopy (3D-SIM) 
 

This method is developed by Lauri Lahti. This method is descripted in this current document written by Lauri 

Lahti, completed and self-archived on 10 September 2021. The first version of this document was completed 

on 10 February 2020. 

To cite this current document please use the following notation: 

Lahti, Lauri (2021). Data analysis supplement to the research article Abouelezz, Stefen, Segerstråle, 

Micinski, Minkeviciene, Lahti, Hardeman, Gunning, Hoogenraad, Taira, Fath, & Hotulainen (2020), 

"Tropomyosin Tpm3.1 Is Required to Maintain the Structure and Function of the Axon Initial Segment". A 

document completed and self-archived on 10 September 2021 in the open-access Aaltodoc publication 

archive at https://aaltodoc.aalto.fi/handle/TO_BE_COMPLETED and http://urn.fi/TO_BE_COMPLETED 

 

This description of the method relies on previous publications and tools (Bob, 2010; Costes et al., 2004; 

Dunn et al., 2011; Fiji/ImageJ program web site, 2020; Herbert, undated; Fiji/ImageJ program 

documentation, 2020; Online Manual for the WCIF-ImageJ collection, undated; Stauffer et al. 2018). 

 

 

1. Launching the Fiji/ImageJ program. 

 

Ensure that you have Fiji/ImageJ program (https://imagej.nih.gov/ij/) installed on your computer environment.  

Then launch the Fiji/ImageJ program.  

 

 

2. Open a hyperstack image file (a hyperstack image file that contains three color channels and each 

of these three channels has a series of images (for example 33 images) taken along the z axis). 

 

In the main command panel window of the Fiji/ImageJ program, select the command path:  

File -> Open… -> 

Select the file name. Let’s assume that we select now file name “phalloidin-ankG-gamma9d-10_copy.tif”. 

Press “Open” button. 

 

A new window (titled “phalloidin-ankG-gamma9d-10_copy.tif”) should open containing the hyperstack image. 

 

 

3. Split the hyperstack image so that each of three color channels is shown as a separate image 

stack.  

 

Select the command path: Image -> Color -> Split Channels 

 

Three new windows (titled “C1-phalloidin-ankG-gamma9d-10_copy.tif”, “C2-phalloidin-ankG-gamma9d-

10_copy.tif” and “C3-phalloidin-ankG-gamma9d-10_copy.tif”) should open, each of them showing an image 

stack (33 frames) for a color channel.  

 

 

4. Identify “the sharpest/brightest” image frames that should be included into the new “z projection 

by max intensity” image versions. 

 

a) 

 

Let’s assume that the channel 2 holds now the most important signal for identifying the region of interest for 

the colocalization analysis concerning the comparison of the signals between the three channels of the 

hyperstack image. 

Thus we now start with the channel 2 image frames (shown in the window titled “C2-phalloidin-ankG-

gamma9d-10_copy.tif”) to identify “the sharpest/brightest” image frames in channel 2. 
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b) 

 

By sliding the scroll bar in the bottom of the window “C2-phalloidin-ankG-gamma9d-10_copy.tif” we can 

browse through the images taken along z axis for channel 2. We can see how in a certain relatively narrow 

range of consecutive frames the image holds “the sharpest/brightest” signal.  

Let’s assume that “the sharpest/brightest” signal of channel 2 emerges in the range of frames 17-19 (i.e. this 

range includes the frame 17, the frame 18 and the frame 19).  

 

Before performing the following command path please make sure that the window “C2-phalloidin-ankG-

gamma9d-10_copy.tif” is currently the most recently active window (if you are unsure, click on the title bar of 

the window “C2-phalloidin-ankG-gamma9d-10_copy.tif” to make it active and do not click on any other 

window before proceeding to the following command path). 

Select the command path: Image -> Stacks -> Z Project… 

 

A new window (titled “Zprojection”) should open. 

 

Useful settings: 

Start slice: 17 

Stop slice: 19 

Projection type: Max intensity 

Press “OK” button. 

 

A new window (titled “MAX_C2-phalloidin-ankG-gamma9d-10_copy.tif”) should open. 

 

c)  

 

As mentioned already in “the step 4a” above let’s indeed assume that the channel 2 holds now the most 

important signal for identifying the region of interest for the colocalization analysis concerning the 

comparison of the signals between the three channels of the hyperstack image. 

 

Thus based on “the step 4b” we should now already know where is approximately the region of interest for 

the hyperstack image also concerning the channel 1 and channel 3. 

 

By sliding the scroll bar in the bottom of the window “C1-phalloidin-ankG-gamma9d-10_copy.tif” we can 

browse through the images taken along z axis for channel 1. We try to identify those frames that hold “the 

sharpest/brightest” signal especially in the region of interest that we already identified in “the step 4b”.  

 

Let’s assume that “the sharpest/brightest” signal of channel 1 (in the desired region of interest based on 

channel 2) emerges in the range of frames 16-18. Note that this range of frames for channel 1 (16-18) is 

different than the range of frames for the channel 2 (17-19). 

 

Before performing the following command path please make sure that the window “C1-phalloidin-ankG-

gamma9d-10_copy.tif” is currently the most recently active window (if you are unsure, click on the title bar of 

the window “C1-phalloidin-ankG-gamma9d-10_copy.tif” to make it active and do not click on any other 

window before proceeding to the following command path). 

Select the command path: Image -> Stacks -> Z Project… 

 

A new window (titled “Zprojection”) should open. 

 

Useful settings: 

Start slice: 16 

Stop slice: 18 

Projection type: Max intensity 

Press “OK” button. 

 

A new window (titled “MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif”) should open. 
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d) 

 

Similarly as was done in “the step 4c” for the channel 1, now let’s identify the range of  “the 

sharpest/brightest” image frames for channel 3. 

 

By sliding the scroll bar in the bottom of the window “C3-phalloidin-ankG-gamma9d-10_copy.tif” we can 

browse through the images taken along z axis for channel 3. We try to identify those frames that hold “the 

sharpest/brightest” signal especially in the region of interest that we already identified in “the step 4b”.  

 

Let’s assume that “the sharpest/brightest” signal of channel 3 (in the desired region of interest based on 

channel 2) emerges in the range of frames 15-17. Note that this range of frames for channel 3 (15-17) is 

different than the range of frames for the channel 2 (17-19) and also different than the range of frames for 

the channel 1 (16-18). 

 

Before performing the following command path please make sure that the window “C3-phalloidin-ankG-

gamma9d-10_copy.tif” is currently the most recently active window (if you are unsure, click on the title bar of 

the window “C3-phalloidin-ankG-gamma9d-10_copy.tif” to make it active and do not click on any other 

window before proceeding to the following command path). 

Select the command path: Image -> Stacks -> Z Project… 

 

A new window (titled “Zprojection”) should open. 

 

Useful settings: 

Start slice: 15 

Stop slice: 17 

Projection type: Max intensity 

Press “OK” button. 

 

A new window (titled “MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif”) should open. 

 

 

5. Save the three separate “z projection by max intensity” image versions. 

 

a) 

 

Make sure that the window “MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif” is currently the most recently 

active window (if you are unsure, click on the title bar of the window “MAX_C1-phalloidin-ankG-gamma9d-

10_copy.tif” to make it active and do not click on any other window before proceeding to the following 

command path) 

. 

Select the command path: File -> Save as -> Tiff…  

 

Select a desired file folder (preferably a specific new folder, such as “channel_1_z_proj_by_max_int”).  

Use the default file name: MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif 

Press “Save” button. 

 

b) 

 

Make sure that the window “MAX_C2-phalloidin-ankG-gamma9d-10_copy.tif” is currently the most recently 

active window (if you are unsure, click on the title bar of the window “MAX_C2-phalloidin-ankG-gamma9d-

10_copy.tif” to make it active and do not click on any other window before proceeding to the following 

command path) 

. 

Select the command path: File -> Save as -> Tiff…  

 

Select a desired file folder (preferably a specific new folder, such as “channel_2_z_proj_by_max_int”).  

Use the default file name: MAX_C2-phalloidin-ankG-gamma9d-10_copy.tif 

Press “Save” button. 
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c) 

 

Make sure that the window “MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif” is currently the most recently 

active window (if you are unsure, click on the title bar of the window “MAX_C3-phalloidin-ankG-gamma9d-

10_copy.tif” to make it active and do not click on any other window before proceeding to the following 

command path). 

. 

Select the command path: File -> Save as -> Tiff…  

 

Select a desired file folder (preferably a specific new folder, such as “channel_3_z_proj_by_max_int”).  

Use the default file name: MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif 

Press “Save” button. 

 

 
MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif 

 

 
MAX_C2-phalloidin-ankG-gamma9d-10_copy.tif 
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MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif 

 

 

6. Create a composite image based on the three separate “z projection by max intensity” image 

versions that were created in “the step 5”. 

 

We assume that based on “the step 5” the windows “MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif”, 

“MAX_C2-phalloidin-ankG-gamma9d-10_copy.tif” and “MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif” are 

still open. 

(If needed, these three images can be opened again with the command path: File – Open… -> etc.) 

 

If any other windows than those three above mentioned windows are currently open, please close them now 

first to prevent a possible malfunctioning. 

 

Select the command path: Image -> Stacks -> Images to stack 

 

Useful settings: 

Name: Stack (the default value) 

Title Contains: (the default value is empty) 

Use Titles as Labels: selected option (checkbox selected) 

Keep Source Images: selected option (checkbox selected) 

Press “OK” button. 

 

A new window (titled “Stack”) should open. 

(Note: For some reason, now sliding the scrollbar of the window “Stack” does not seem to function as 

expected (i.e. the three separate channel images do not seem to appear as expected). Despite of this 

strange behavior anyway in the following actions it seems that the composite image correctly includes the 

separate channel images.) 

 

Make sure that the window “Stack” is currently the most recently active window (if you are unsure, click on 

the title bar of the window “Stack” to make it active and do not click on any other window before proceeding 

to the following command path). 

 

Select the command path: Image -> Color -> Make composite 

 

The outlook of the window “Stack” should now change so that it shows a composite image that indicates with 

three different colors the signals of the three channels (channel 1 indicated with red color, channel 2 

indicated with green color and channel 3 indicated with blue color).  

 

Make sure that the window “Stack” is currently the most recently active window (if you are unsure, click on 

the title bar of the window “Stack” to make it active and do not click on any other window before proceeding 

to the following command path). 
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Select the command path: File -> Save as -> Tiff…  

Select a desired file folder (preferably a specific new folder, such as “composite_z_proj_by_max_int”).  

Use a file name that matches the original source file names:  

phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite.tif 

Press “Save” button. 

 

 
phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite.tif 

 

 

7. With a separate drawing program (for example the Gimp program, see https://www.gimp.org/) 

create an outline image defining the region of interest for colocalization analysis.  

 

How an outline image defining the region of interest can be created with the Gimp program: 

 

In the Gimp program, select the command path: File -> Open…  

Select a desired file folder containing the appropriate composite image that was created in “the step 6” (let’s 

assume that this folder is “composite_z_proj_by_max_int”).  

Select the file name of the appropriate composite image, for example “phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite.tif”. 

Press “Open” button. 

The composite image should appear into the editing area of the Gimp program (channel 1 indicated with red 

color, channel 2 indicated with green color and channel 3 indicated with blue color). 

 

As mentioned already in “the step 4a” above let’s indeed assume that the channel 2 holds now the most 

important signal for identifying the region of interest for the colocalization analysis concerning the 

comparison of the signals between the three channels of the hyperstack image. Since in the composite 

image the channel 2 is indicated with the green color, we can now create a white outline image defining the 

region of interest for colocalization analysis so that we draw a thin white line approximately along the outer 

borders of the green color patterns (approximately means here that we try to make sure that relevant bright 

pixel areas also in the other channels 1 and 3 can be captured inside the white outline). To make this white 

outline image it is possible to do the following actions: 

 

Important: 

To prevent malfunctioning and possible error messages in the later launching of “EzColocalization” with 

Analyze button it is important to ensure that the white drawn outline area never touches the outermost 

borders of the image, instead there must always be at least one pixel of black color on the outer edge of the 

image’s borders.  
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The final “outline image” should have the region of interest painted with white color pixels on a black 

background. 

In the Gimp program, select the command path: Layer -> New Layer… -> (Fill with: Transparency) -> OK 

Draw a white line on the new layer with the Pencil Tool: First click with the mouse on a suitable place on the 

image to create a starting point for a line and then add new line segments so that for the following clicks 

keep also the shift button pressed down. The white line should form a closed loop and then it should be filled 

with white color by using he Bucket Fill Tool. Thus the final “outline image” should contain a region of white 

color pixels (i.e. the region of interest) that is on a black background. 

 

The outline image can be exported in the Gimp program by selecting the command path: File -> Export as… 

 

It is practical to export two different output versions: a) “outline layered” and b) “only outline with inside filled”. 

 

 

Case 1/2: Before the inside of the outlined area is filled with white color by using the Bucket Fill Tool:  

 

a) Exporting "outline layered" image: 

It can be practical to export now to png image format. 

Keep visible all layers of the image. 

Select a desired file folder (preferably such as "composite_z_proj_by_max_int").  

Select the file name, for example "phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite_outline_layered.png". 

Press "Export" button, etc. 

 

 
phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite_outline_layered.png 

 

 

Case 2/2. After the inside of the outlined area is filled with white color by using the Bucket Fill Tool:  

 

b) Exporting "only outline with inside filled" image: 

It is important to export now to tiff image format. 

Keep visible only the layer that holds the white color pixels that define the region of interest. 

Select a desired file folder (preferably such as "composite_z_proj_by_max_int").  

Select the file name, for example "phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite_outline_filled.tif". 

Press "Export" button, etc. 
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Please note: Due to some possible format encoding challenges or settings it might turn out that the images 

exported from Gimp program might not always open as expected in the Fiji/ImageJ program. Anyway, the 

essential aim is to create and export an "only outline with inside filled" image that indicates the region of 

interest with white color pixels on a black background. 

 

 
phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite_outline_filled.tif 

 

 

8. Install the Fiji/ImageJ "EzColocalization Plugin". 

 

Install the Fiji/ImageJ "EzColocalization Plugin" that is available from: 

Stauffer, W., Sheng, H., and Lim, H.N. (2018). EzColocalization: An ImageJ plugin for visualizing and 

measuring colocalization in cells and organisms. See https://www.nature.com/articles/s41598-018-33592-8 

and https://sites.imagej.net/EzColocalization/plugins/ 

 

 

9. Make colocalization analysis with the Fiji/ImageJ "EzColocalization Plugin"  

 

The colocalization analysis enables comparing the signals between two channels of the hyperstack image in 

a "region of interest" defined by the outline image. 

 

Let's assume that we are now observing the data originating from the file "phalloidin-ankG-gamma9d-

10_copy.tif". 

We want to compare signals between channel 1 and channel 3 in the "region of interest" defined by the 

outline image. Thus we first open three appropriate images. 

 

In the Fiji/ImageJ program do the following actions: 

 

To prevent malfunctioning and errors, please preferably first close all currently open windows except the 

main command panel window of the Fiji/ImageJ program. 

 

Important: 

It is recommendable to make sure that the "EzColocalization" window is not yet opened before opening any 

image files. If the "EzColocalization" window is already open before the image files are opened, it seems that 

some settings of the "EzColocalization" window do appear only partially available. 
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How to open images for "EzColocalization"? 

 

RECOMMENDED: It seem to be preferable to open the images through the traditional drop-down "File 

menu" that is located in the main command panel window of the Fiji/ImageJ program. 

 

(NOT RECOMMENDED: It seems that one suggested practice for opening the image files for the 

"EzColocalization Plugin" is to do it through the drop-down "File menu" that is located in the 

"EzColocalization" window (a separate window that shows the adjustable settings for the "EzColocalization 

Plugin". Unfortunaltely using this strategy seems to cause sometimes that some settings of the 

"EzColocalization" window do appear only partially available.)  

 

 

a) Open the "z projection by max intensity" image version of channel 1   

 

Through the traditional drop-down "File menu" that is located in the main command panel window of the 

Fiji/ImageJ program, select the command path:  

File -> Open... 

Select a desired file folder (for example "channel_1_z_proj_by_max_int", like in "the step 5").  

Select a file name, for example MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif 

Press "Open" button. 

 

 

b) Open the "z projection by max intensity" image version of channel 3  

 

Through the traditional drop-down "File menu" that is located in the main command panel window of the 

Fiji/ImageJ program, select the command path: 

File -> Open... 

Select a desired file folder (for example "channel_3_z_proj_by_max_int", like in "the step 5").  

Select a file name, for example MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif 

Press "Open" button. 

 

 

c) Open the "outline image" that defines the region of interest (illustrated with a region of white color pixels 

on a black background) 

 

Through the traditional drop-down "File menu" that is located in the main command panel window of the 

Fiji/ImageJ program, select the command path:  

File -> Open... 

Select a desired file folder (for example "composite_z_proj_by_max_int", like in "the step 7").  

Select the file name, for example "phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite_outline_filled.tif". 

Press "Open" button. 

 

Important: 

As already mentioned in "the step 7", please note this specific requirement for the "outline image": To 

prevent malfunctioning and possible error messages in the later launching of "EzColocalization" with Analyze 

button it is important to ensure that the white drawn outline area never touches the outermost borders of the 

image, instead there must always be at least one pixel of black color on the outer edge of the image's 

borders.  

 

If along the steps a), b) and c) there appears a warning message "The calibration of this image conflicts with 

the current global calibration", then select the following settings in the warning window: 

 

Selected checkbox: Disable Global Calibration 

Not selected checkbox: Disable these Messages 

Finally press "OK" button. 
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d) The "outline image" must be converted to be a mask 

 

Do the conversion in the following way: 

 

Make sure that the window "phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite_outline_filled.tif" is 

currently the most recently active window  

(if you are unsure, click on the title bar of the window "Stack" to make it active and do not click on any other 

window before proceeding to the following command path). 

 

In the main command panel window of the Fiji/ImageJ program, select the command path:  

Process -> Binary -> Convert to mask 

 

 

e) Scaling factors must be made consistent/global 

 

Note: This action is important, if this is not performed, the later launching of "EzColocalization" with Analyze 

button will bring an error message: Scaling factors must be consistent/global. Reset the Scale in "Analysis -> 

Set scale…". 

 

In the main command panel window of the Fiji/ImageJ program, select the command path:  

Analysis -> Set scale… ->  

Press button "Click to remove scale" 

Select option "Global" 

Press button "OK".  

 

Thus the following values were accepted by pressing button "OK": 

Distance in pixels: 0.00 

Know distance: 0.00 

Pixel aspect ratio: 1.0 

Unit of length: pixel 

Selected checkbox: "Global" 

Scale: <no scale> 

 

 

f) Launch "EzColocalization Plugin" 

 

In the main command panel window of the Fiji/ImageJ program, select the command path:  

Plugins -> EzColocalization 

 

A new window titled "EzColocalization" should appear. 

 

 

g) Adjust the settings in the "Inputs tab" of the "EzColocalization" window  

 

Note: In the "Inputs tab" of the "EzColocalization" window there are settings that define "Reporter 1 (Ch. 1)", 

"Reporter 2 (Ch. 2)" and "Cell identification input". Here the notations Ch. 1 and Ch. 2 do not necessarily 

refer to channels 1 and 2 specifically but instead two different channels that the user can select among 

various channel alternatives according to his/her will. Thus also in the following guidance example you can 

see that the settings for "Reporter 2 (Ch. 2)" are used to refer to channel 3 of the hyperstack image. 

 

Some settings in the "Inputs tab" of the "EzColocalization" window should become automatically updated.  

If the settings that define "Reporter 1 (Ch. 1)", "Reporter 2 (Ch. 2)" and "Cell identification input" become 

automatically updated in a wrong way, you can manually ensure that the settings are like this in the "Inputs 

tab": 

 

Images for analysis: 

Reporter 1 (Ch. 1): MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif 
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Reporter 2 (Ch. 2): MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif 

Cell identification input: phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite_outline_filled.tif 

 

Alignment and threshold options: 

Not selected checkbox: Align Reporter 1 (Ch. 1): Default 

Not selected checkbox: Align Reporter 2 (Ch. 2): Default 

 

 

h) Keep the default settings in the "Cell Filters tab" of the "EzColocalization" window  

 

Ensure that the settings are like this in the "Cell Filters tab": 

 

Area: 0-Infinity 

 

Not selected checkbox: Watershed segmentation 

 

Cell filter 1 Area 0-Infinity 

Cell filter 2 AR 0-Infinity 

Cell filter 3 Mean (Ch.1) 0-Infinity 

Cell filter 4 Mean (Ch.2) 0-Infinity 

Cell filter 5 Min (Ch.1) 0-Infinity 

Cell filter 6 Min (Ch.2) 0-Infinity 

Cell filter 7 Max (Ch.1) 0-Infinity 

Cell filter 8 Max (Ch.2) 0-Infinity 

 

 

i) Adjust the settings in the "Visualization tab" of the "EzColocalization" window  

 

Adjust the settings in the "Visualization tab" of the "EzColocalization" window to be like this: 

 

Heat maps 

Scaling options: 

Selected radio button option: cell 

Color maps: 

Selected checkbox: Channel 1 hot 

Selected checkbox: Channel 2 cool 

 

Scatterplots 

Selected checkbox: Cell pixel intensity scatterplots 

 

Metric matrices 

Selected checkbox: Matrices of different combinations of fractions 

FT (Ch.1): 10 % 

FT (Ch.2): 10 % 

Metric: PCC 

Average: Median 

 

 

j) Adjust the settings in the "Analysis tab" of the "EzColocalization" window 

 

Adjust the settings in the "Analysis tab" of the "EzColocalization" window to be like this: 

 

 

In the "Analysis Metrics sub-tab": 

 

Colocalization metrics: 

Selected checkbox: TOS, also selected radio button "Costes'" 

Selected checkbox: PCC, also selected radio button "All" 
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Selected checkbox: SRCC, also selected radio button "All" 

Selected checkbox: ICQ, also selected radio button "All" 

Selected checkbox: MCC, also selected radio button "Costes'"  

 

Other metrics: 

Selected checkbox: Average signal  

Not selected checkbox: Custom Metric 

Selected checkbox: Summary  

Not selected checkbox: Histogram(s) 

Not selected checkbox: Mask(s) 

Not selected checkbox: ROI(s) 

 

 

In the "Metrics info sub-tab":  

Keep the default settings. 

 

 

In the "Custom sub-tab":  

Keep the default settings. 

 

 

10. Launch calculations of the "EzColocalization" window.  

 

In the bottom of the “EzColocalization” window press the button “Analyze”. This should launch calculations 

and. Based on the above mentioned settings, two specific results windows should appear: a window titled 

“Metric(s) of…” and a window titled “Log”. Also some supplementing visualization results should appear in 

additional windows. 

 

 

a) 

 

The window “Metric(s) of…” should provide numerical results that are like the following ones: 

 

Label TOS(linear) TOS(log2) PCC SRCC ICQ M1 M2 
image 1: 
cell 1 NaN NaN 0.605 0.754 0.329 0.979 1 

 

Avg.Int.C1 Avg.Int.C2 Area X Y XM YM Perim. 

4299.831 8491.970 16032 239.993 298.688 239.993 298.688 1484.844 
 

BX BY Width Height Major Minor Angle Circ. 

2 81 509 430 474.109 43.055 39.626 0.091 
 

Feret FeretX FeretY FeretAngle MinFeret AR Round Solidity 

666.319 2 511 40.191 77.103 11.012 0.091 0.431 
 

 

b) 

 

The window “Log” should provide textual results that are like the following ones: 

 

Results Summary: 

 

Reporter 1 (Ch.1) image(s): MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif (Unaligned) 

Reporter 2 (Ch.2) image(s): MAX_C3-phalloidin-ankG-gamma9d-10_copy.tif (Unaligned) 

Cell identification input image(s): phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite_outline_filled.tif  
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Number of cells analyzed = 1 

  

  

Threshold Overlap Score linearly rescaled [TOS(linear)]  

  

mean = NaN 

standard deviation = NaN 

median = NaN 

 

Interpretation:  

TOS(linear) is a measure of the overlap of pixels above the threshold for two or three reporter channels, 

normalized for the expected overlap to occur by chance, which is rescaled so the value is a fraction of the 

difference between the null hypothesis and the maximum possible colocalization or anticolocalization for the 

selected thresholds. 

For example, 0.5 is halfway between the null distribution and complete overlap for the selected percentages. 

 

-1 = complete anticolocalization 

0 = noncolocalization 

1 = complete colocalization 

  

Threshold Overlap Score logarithmically rescaled [TOS(log2)]  

  

mean = NaN 

standard deviation = NaN 

median = NaN 

  

Interpretation:  

TOS(log) is the same as TOS(linear) except the rescaling is logarithmic instead of linear. 

For example: 0.5 is halfway between the null distribution and complete overlap of selected percentages on 

the log scale. 

 

-1 = complete anticolocalization 

0 = noncolocalization 

1 = complete colocalization 

  

Pearson’s Correlation Coefficient (PCC)  

  

mean = 0.6054364144631682 

standard deviation = 0.0 

median = 0.6054364144631682 

  

Interpretation:  

PCC measures the correlation between the pixel values for two reporter channels. 

 

-1 = complete anticolocalization 

0 = noncolocalization 

1 = complete colocalization 

  

Spearman’s Rank Correlation Coefficient (SRCC)  

  

mean = 0.7542064512612362 

standard deviation = 0.0 

median = 0.7542064512612362 

  

Interpretation:  

SRCC measures the ranked correlation of pixel values for two reporter channels. 
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-1 = complete anticolocalization 

0 = noncolocalization 

1 = complete colocalization 

  

Intensity Correlation Quotient (ICQ)  

  

mean = 0.32865518962075846 

standard deviation = 0.0 

median = 0.32865518962075846 

  

Interpretation:  

ICQ measures the proportion of pixels that are below or above the mean for all of two or three reporter 

channels. 

 

-0.5 = complete anticolocalization 

0 = noncolocalization 

0.5 = complete colocalization 

  

Manders’ Colocalization Coefficient (MCC; components M1, M2, and M3) of Channel 1  

  

mean = 0.9790980173524887 

standard deviation = 0.0 

median = 0.9790980173524887 

  

Interpretation:  

MCC measures the intensity weighted proportion of signal which overlaps above the thresholds for two or 

three channels. 

 

0 = complete anticolocalization  

1 = complete colocalization  

  

Manders’ Colocalization Coefficient (MCC; components M1, M2, and M3) of Channel 2  

  

mean = 1.0 

standard deviation = 0.0 

median = 1.0 

  

Interpretation:  

MCC measures the intensity weighted proportion of signal which overlaps above the thresholds for two or 

three channels. 

 

0 = complete anticolocalization  

1 = complete colocalization  

  

Average Signal Intensity (Avg.Int.) of Channel 1  

  

mean = 4299.8313373253495 

standard deviation = 0.0 

median = 4299.8313373253495 

  

Interpretation:  

Selection of the average signal intensity option generates a table that has the average signal intensity of 

each reporter channel and the physical measurements of each cell in the sample. 

  

Average Signal Intensity (Avg.Int.) of Channel 2  

  

mean = 8491.969810379242 

standard deviation = 0.0 
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median = 8491.969810379242 

  

Interpretation:  

Selection of the average signal intensity option generates a table that has the average signal intensity of 

each reporter channel and the physical measurements of each cell in the sample. 

  

----------------------------------------------------- 

 

 

c)  

 

Some supplementing visualization results should appear like the following ones: 

 

 

 
Heatmap(s) of MAX_C1-phalloidin-ankG-gamma9d-10_copy.tif-2.tif 

 

 
Heatmap(s) of MAX_ C3-phalloidin-ankG-gamma9d-10_copy.tif-2.tif 
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PCC of phalloidin-ankG-gamma9d-10_copy_stack_ch123_composite_outline_filled.tif 

 

 
Scatterplots of random cells in phalloidin-ankG-gamma9d-

10_copy_stack_ch123_composite_outline_filled_modified.tif 

 

 

11. Exporting numeric values and visualization results for further use. 

 

The numeric values generated into the window titled "Metric(s) of..." and into the window titled "Log" can be 

copied to a spreadsheet program or statistics program to perform further analysis. 

 

The generated visualization results can be saved with a specific script (sometimes the saved images can 

become a bit distorted or some of them may not become saved at all, then try to save images manually, for 

example by taking screen shots): 
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a) 

 

Save the following script code to a new text file (let's assume that the file name is 

"saving_script_by_lauri_lahti_20200210.txt": 

 

dir = getDirectory("Choose a Directory"); 

ids=newArray(nImages); 

for (i=0;i<nImages;i++) { 

        selectImage(i+1); 

        title = getTitle; 

        print(title); 

        ids[i]=getImageID; 

 

        saveAs("tiff", dir+title); 

} 

 

 

b) 

 

To launch the above mentioned saving script:  

 

In the main command panel window of the Fiji/ImageJ program, select the command path:  

Plugins -> Macros -> Run... 

Select a desired file folder (the folder that holds the script "saving_script_by_lauri_lahti_20200210.txt").  

Select the file name. In the following we assume that we use the file name 

"saving_script_by_lauri_lahti_20200210.txt". 

Press "Open" button. 

 

A new window (titled "Choose a Directory") should open. 

Now select the desired output folder for saving the visualization results. 

Press button "Select". 

 

Visualization results should become now saved into the selected output folder.  

(Sometimes the saved images can become a bit distorted or some of them may not become saved at all, 

then try to save images manually, for example by taking screen shots). 

 

 

12. Starting a new round for analyzing colocalization  

 

Now it is possible to start a new round for analyzing colocalization in the Fiji/ImageJ program.  

You can start repeating “the steps 6-11” described above but still before that note the following: 

To prevent malfunctioning and errors, please preferably first close all currently open windows except the 

main command panel window of the Fiji/ImageJ program. 

Thus please now close all still open image windows, "EzColocalization" window, the window "Metric(s) of...", 

the window "Log" and all visualization results.  

Then you can proceed back to “the step 6” and start a new round for analyzing colocalization. 
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